Difference between revisions of "Talk:OpenTyrianWii"

From WiiBrew
Jump to navigation Jump to search
Line 25: Line 25:
 
: Mattman, try loading it via the homebrew loader for now.  I've been posting around that I have a possible fix in the next release, but it's not guaranteed, and the release is a couple of days of yet.  [[User:Molokai|Molokai]] 20:20 PDT, 28 May 2009
 
: Mattman, try loading it via the homebrew loader for now.  I've been posting around that I have a possible fix in the next release, but it's not guaranteed, and the release is a couple of days of yet.  [[User:Molokai|Molokai]] 20:20 PDT, 28 May 2009
 
:: New version out, could possibly have the fix for this.  [[User:Molokai|Molokai]] 22:20 PDT, 28 May 2009
 
:: New version out, could possibly have the fix for this.  [[User:Molokai|Molokai]] 22:20 PDT, 28 May 2009
 +
 
::: Okay, thank you.  The new version works perfectly.--[[User:MattMan|MattMan]] 20:35, 29 May 2009 (UTC)
 
::: Okay, thank you.  The new version works perfectly.--[[User:MattMan|MattMan]] 20:35, 29 May 2009 (UTC)
 
V1.1.2 works great for me and I was having trouble getting V1.1.1 to work with HBC 1.0.3! When using the Wiimote horizontally, don't you think it makes more sense to have the "Fire" button be button "2" rather than "A"? Thanks! --[[User:SuperWario|SuperWario]] 15:41, 29 May 2009 (UTC)
 
V1.1.2 works great for me and I was having trouble getting V1.1.1 to work with HBC 1.0.3! When using the Wiimote horizontally, don't you think it makes more sense to have the "Fire" button be button "2" rather than "A"? Thanks! --[[User:SuperWario|SuperWario]] 15:41, 29 May 2009 (UTC)
 
: Look here and read my first post.  You'll understand after that: [http://www.tehskeen.com/forums/showthread.php?t=11881 tehskeen].  The main problem is that SDL Wii isn't set up to change the control scheme of the Wiimote to a horizontal type automatically.  I have the config coded to rig all four Wiimote "joysticks" for use with the Nunchuck by default.  Hence my question on tehskeen.  [[User:Molokai|Molokai]] 16:08 PDT, 29 May 2009
 
: Look here and read my first post.  You'll understand after that: [http://www.tehskeen.com/forums/showthread.php?t=11881 tehskeen].  The main problem is that SDL Wii isn't set up to change the control scheme of the Wiimote to a horizontal type automatically.  I have the config coded to rig all four Wiimote "joysticks" for use with the Nunchuck by default.  Hence my question on tehskeen.  [[User:Molokai|Molokai]] 16:08 PDT, 29 May 2009

Revision as of 22:36, 29 May 2009

Thanx

Just wanted to say, thanx for this release, I have never been able to get Nuvalo's working, It must hate my wiimote :D great game, i'l keep an eye on this :) Uhmm, just had a game, the wiimote is bizarre at startup, and the screen is totally offset, and it exceptions when exiting. djdynamite123 10:22, 25 May 2009 (UTC)

Yes, I set up the control scheme table on the main page, you need to have the Nunchuk plugged in and use it to navigate. Other than that, I'm not sure what you're getting at with "bizarre". The screen offset is purposeful, as the source video is 320x200, and upscaled to 640x400. If enough people want, I will look into upscaling to 640x480. As for the exception when exiting, to get around that for now, press the reset button on the Wii. It returns to the HBC. I should have that fixed in the next release. Molokai 12:27 PDT, 25 May 2009

great, yeah the scaling to 640x480 is more like it :) great work! I'l have another try shortly, do we have to use numchuk? djdynamite123 20:39, 25 May 2009 (UTC)

Yes, Nunchuk is required for use with the Wiimote. There's currently no way (that I know of) to use the Wiimote by itself (Tyrian doesn't recognize the Dpad inputs). I should be able to set that up when I edit the configuration settings. Molokai 13:47 PDT, 25 May 2009

Great, would be cool without the nunchuk, it it would feel much better. I could never get Nuvalo's wii-linux based Tyrian to recognise my wiimote, which was a shame all this time. Anyway can't wait for updates :) djdynamite123 21:52, 25 May 2009 (UTC)

Yeah, it was pretty tricky. But when I was able to get it to recognize mine, I think I didn't realize at the time it was set up exactly the way this is set up now. BTW, I'm thinking I might not even bother with tehskeen, if you want to take care of that instead, feel free. Molokai 13:47 PDT, 25 May 2009

That's up to you about tehskeen, anyway great job on new release, works perfectly, If we can get simple wiimote support only, and fullscreen I will be happy as they come :) djdynamite123 11:44, 26 May 2009 (UTC)

I'm another throwing my vote in for 640*480 upscaling. Also curious if im the only one getting popping audio? mobilisq

No, I forgot to mention I'm getting the same really strange popping audio sound, any idea why this is? also can't wait for fullscreen and network play!!! nice wiimote only support yippee :) djdynamite123 18:44, 27 May 2009 (UTC)

Unfortunately, I think the popping sound is due to the music being sampled at 32khz (and the Wii outputting that), but the sound effects are currently sampled at 33khz (since I have not gotten a proper resampler in place for those). I did this, for now, because I wanted to get it out, and I thought it was passable enough. You can just turn the sound effects down for now, and it's not so noticeable. (I have this theory because I think I remember going into the Jukebox and letting the music play and not getting any popping or crackling).

As for the 640x480, I'm working on it now. Molokai 12:09 PDT, 27 May 2009

Well, the 640x480 could take a little while, as it will require some bilinear interpolation to make it look very good. If anyone has any experience with that, I would appreciate the help (I'm starting basically from scratch as far as the coding goes). Molokai 18:29 PDT, 27 May 2009

Problem Loading Game

I am having trouble getting this to work. I have the tyrian folder in the root of my sd card and the opentyrianwii folder in my apps folder, but when I load the game from the homebrew channel, a black screen with white typing flashes for a fraction of a second and then returns to the homebrew channel. I'm not sure why this isn't working, so perhaps someone could help me out?--MattMan 20:35, 29 May 2009 (UTC)

Mattman, try loading it via the homebrew loader for now. I've been posting around that I have a possible fix in the next release, but it's not guaranteed, and the release is a couple of days of yet. Molokai 20:20 PDT, 28 May 2009
New version out, could possibly have the fix for this. Molokai 22:20 PDT, 28 May 2009
Okay, thank you. The new version works perfectly.--MattMan 20:35, 29 May 2009 (UTC)

V1.1.2 works great for me and I was having trouble getting V1.1.1 to work with HBC 1.0.3! When using the Wiimote horizontally, don't you think it makes more sense to have the "Fire" button be button "2" rather than "A"? Thanks! --SuperWario 15:41, 29 May 2009 (UTC)

Look here and read my first post. You'll understand after that: tehskeen. The main problem is that SDL Wii isn't set up to change the control scheme of the Wiimote to a horizontal type automatically. I have the config coded to rig all four Wiimote "joysticks" for use with the Nunchuck by default. Hence my question on tehskeen. Molokai 16:08 PDT, 29 May 2009