Difference between revisions of "Talk:Priiloader"

From WiiBrew
Jump to: navigation, search
(Changelog needs update?: new section)
Line 189: Line 189:
 
:Thanks all!!!
 
:Thanks all!!!
 
:[[User:Bertm|Bertm]] 19:07, 19 February 2010 (UTC)
 
:[[User:Bertm|Bertm]] 19:07, 19 February 2010 (UTC)
 +
 +
== Changelog needs update? ==
 +
 +
How exactly does the changelog need updating? --[[User:Dialexio|<span style="color:#C20; font-weight:normal;">Dialexio</span>]] 05:02, 1 August 2010 (UTC)

Revision as of 07:02, 1 August 2010

talk about priiloader here

Feature Request: BGM

If someone can make a hack to turn off system menu background music, what about a hack that simply *changes* the background music to a music file of your choice, such as a file stored on SD? Can it be done? Should it be done? --Iwata-san 03:48, 29 June 2010 (UTC)


Feature Request

Any chance of getting the black screen with white letters back, or at least making it an option to select black or white background and saving in the hacks.ini file? I do love how the new Priiloader works, and that it supports SDHC cards now. --Donsch 23:50, 24 November 2009 (UTC)

its actually already added now. see svn. 0.2 will have both themes.--DacoTaco 05:00, 27 November 2009 (UTC)


WiiRemote Disconnection

When I load the .dol file, it comes up with the screen saying "priiloader rev 15 (preloader v0.30b) Installation / Removal Tool...Please Press Plus To Install Or Minus To Remove" but then the WiiRemote disconnects, and pressing any of the buttons on it just makes the lights flash, and it can't reconnect, leaving me to having to hard power off the Wii. --Xiphiidae 00:28, 7 November 2009 (UTC)

youre trying to use CIOS aren't you (by holding B and the + or - )? its the only time the installer disconnects all wiimotes (and when installer is done but this isn't the case)--DacoTaco 00:38, 7 November 2009 (UTC)
No, I'm not pressing any buttons, the WiiRemote disconnects as soon as the .dol loads.--Xiphiidae 00:41, 7 November 2009 (UTC)


are you running this from Homebrew channel? if so, reinstall IOS36 with trucha&ES_DIVerify. i dont see why the WPAD_Init should fail like that--DacoTaco 08:59, 7 November 2009 (UTC)

Done that, nothing changed, WiiRemote still disconnects.--Xiphiidae 09:32, 7 November 2009 (UTC)
Okay, got it working, and I installed it fine, but now, even though my system menu loads fine, a few seconds after I put a disc in the Wii, all Wiimotes disconnect and it just keeps reading the disc (Wii+GC Disc icons in disc channel keep spinning), it looks like I can't play games now. --Xiphiidae 10:12, 7 November 2009 (UTC)
what settings in priiloader are you using? if i can recreate the bug maybe i can fix it. and what system version are you on --DacoTaco 10:27, 7 November 2009 (UTC)
I'm on 4.2E, and I've got the SysMenu running on IOS70, Priiloader autoboots to SysMenu, both the 'Stop Disc' and 'Ignore Standby Setting' options with Priiloader are both turned off, and I've turned all the Menu Hacks off and the problem persists. --Xiphiidae 10:34, 7 November 2009 (UTC)
is it set in settings to load ios 70 or just use system menu ios? cause im on 4.2 and it works fine...--DacoTaco 10:57, 7 November 2009 (UTC)
It's set to use the System Menu IOS. --Xiphiidae 11:00, 7 November 2009 (UTC)
did phpgeek's rev4 or the priiloader beta show this problem?--DacoTaco 11:21, 7 November 2009 (UTC)
This version: http://www.nyleveia.com/daco/dlpriiloader.php?ver=0_1 --Xiphiidae 11:24, 7 November 2009 (UTC)


I seem to be having the same problem as DacoTaco is having above, in that I have just updated from Preloader rev4 by phpgeek to the new Priiloader and my Wii no longer recognises Wii disks in the Wii Menu although GameCube discs appear to work fine. I have to load all my games via Gecko 1.9.3. Also I just tried to load the Homebrew Channel from the Wii Menu with a disc inserted and I just got a black screen and it wouldn't load any further. I can only guess that when you fixed the disc spinning bug and closed the dvd drive it now can't access it at all. I will now see if I can remove Priiloader completely or downgrade again to Preloader rev4. I'm running System Menu 3.2E JP 14:06, 7 November 2009 (UTC)

@ both JP as Xiphiidae : i need to know what your wii settings are (the shut down settings, wc24,resolution etc etc ) + priiloader settings + if your system menu ios is patched with anything and what its patched with. no this does not have anything to do with the DVD spin bug beeing killed. or at least it shouldn't. --DacoTaco 14:18, 7 November 2009 (UTC)

Crash & Bug Reports

Has there been much testing yet with bannerbomb method? I'm have a Wii with 4.2u on it - if I run Priiloader with Bannerbomb v2, I get the same message as if I ran it through HBC with an unpatched IOS36, only it shows IOS70(expected) and gives me a code dump before locking the console (unexpected...) JustMe 21:15, 7 November 2009 (UTC)

when does it crash in the installer? and can i get a picture of the code dump? technically it should work 100% --DacoTaco 21:29, 7 November 2009 (UTC)
Running the installer through HBC(unpatched IOS) gives the message shown in picture 1. After that it exits back to HBC. Running the installer through BannerBomb v2 shows the same message, being relevant to IOS70. After the message is displayed though, it then does a code dump(picture 2) and locks the console. The Wii is nearly stock off-the-self. Right now it only has HBC, DVDx and BootMii-IOS loaded on it. No other modifications. Picture 1 Picture 2 --JustMe 15:47, 8 November 2009 (UTC)
odd. it worked fine on my patch free ios70 with bannerbomb... :/ the code dump is prob the exit failing. ill look into it if i have time... in the mean time; try finding a safe guide to patch trucha/es_DIverify on ios36.--DacoTaco 17:35, 8 November 2009 (UTC)
I looked at the source of the installer and there's a comment in it which says that to have NAND permissions, SU needs trucha i.e. you need to have trucha and ES_Identify in IOS70, or if you use bannerbomb, you should be able to manage with just trucha. But from the looks of things you do need trucha in IOS70. --SifJar 16:59, 8 November 2009 (UTC)
i know, but my ios70 is clean of any patching and it worked... :/ thats why im kinda suprised. mind testing on a clean ios yourself? --DacoTaco 17:35, 8 November 2009 (UTC)
I will try when I have installed BootMii as boot2 (I know, I should have done it LONG ago, I'll try and get it done soon.) I( have no patched IOS anyway, so I'll just need to install BootMii. However, I think you have realised that it only worked for you because it was already installed so did not need to patch the System Menu .tik --SifJar 20:05, 10 November 2009 (UTC)
it never patches the system menu tik. it copies it to the system menu path so any homebrew can access it without nand permissions or trucha (to give "su" access). but ye, i understand now anyway.--DacoTaco 22:08, 10 November 2009 (UTC)
You knew what I meant =P --SifJar 22:11, 10 November 2009 (UTC)

I can crash the Priiloader every time by loading a file to install, then choosing installed file. The funny thing is that after power cycling the Wii, it actually does run the installed file successfully.--Donsch 23:55, 24 November 2009 (UTC)

and what dol would you be installing?--DacoTaco 05:00, 27 November 2009 (UTC)

The disable bgm setting doesn't work for some reason.--Sambena 14:16, 11 December 2009 (UTC)

Priiloader v.02 only boots system menu every other time. I have noticed others on Tehskeen who have the same problem.--Sambena 03:26, 13 December 2009 (UTC)

When using "Remove NoCopy Save File Protection" on System menu 4.1J with the correct hacks.ini copying of savegames from sd to flash or deleting savegames from flash will freeze the wii. In the case of deleting savegames from flash, this will cause the wii savegame menu to freeze while loading. Gannon 00:57, 21 December 2009 (UTC)

question is, is that related to priiloader or the hacks? if its the hacks then lol@person who made it :) --DacoTaco 06:31, 21 December 2009 (UTC)

I just upgraded to Priiloader v0.3 rev45 and this fixed the bug from v0.2 where when shutting down from a game it loaded straight to priiloader instead of autoboot. But now I can't get the new feature when no wiimote is sync'd to boot to System Menu. I boot Priiloader holding reset, then wait 15 seconds, there is no display or hint to when to push the button again so I count to 20 and push reset and nothing, it doesn't boot to system menu and wait longer and try again and still nothing. I'd really like to get this working as it will help a lot of people with unsync'd remotes and no GC controller. Stryk3r 00:31, 14 January 2010 (UTC)

cause the code doing that isn't in the SVN yet. use the beta found here . it has the code to use reset to autoboot and will get in SVN once i plan to add something else to 0.3 (highly unlikely) or when 0.3 gets publicly released (which is very soon).--DacoTaco 06:20, 14 January 2010 (UTC)

Interesting Info from DacoTaco

according to DacoTaco, if you run the installer with bannerbomb (or from priiloader itself) , you do not need ANY patched IOS at all, even for installation. Which I think is pretty interesting. Felt I should mention it here. --SifJar 12:33, 7 November 2009 (UTC)

Felt I should add that you actually still need trucha bug in System Menu IOS for this to work. ES_Identify patch isn't needed though. --SifJar 22:00, 21 November 2009 (UTC)

Can't boot into system menu

I installed priiloader with a proper hacks.ini and when I rebooted it loaded into the main menu and stopped there. I than try to laod into system menu and it just reboots back into the priiloader menu. I can boot into homebrew channel and boot into bootmii just not into system menu. I am using system menu 4.0u. Please help. Oh I tried to unintall and it gives me an error telling me aborting mission. -Sambena —Preceding unsigned comment added by Sambena (talkcontribs) 03:40, 10 November 2009 (UTC)

what is the error when uninstalling?its not going to say aborting mission without a reason. and is there any error you get to see when you try and boot system menu? --DacoTaco 05:52, 10 November 2009 (UTC)
Sorry, I had a feeling I should of waited to fix my problem after talking to you. Now I have no useful information to pass on to you. I concluded one of three things happened. Either my system menu got corrupted, Priiloader was pointing to itself (doubtful) or my ios60 didn't have truncha. I am going with option three. I thought the installer was suppose to patch ios60, but mine didnt get patched. I know this because I restored my system menu (downloaded with nusd) and imported it with a program made by voldemort (the coder that shall not be named here at wiibrew) I know this is a very dangerous thing to do and shouldn't be done by anyone unless they know what they are doing. (insert standard I accept no responsibility clause and moving on)I than installed preloader v.30 and I got a ES_identify error on ios60. which is weird, becuase I tried using ios36 in priiloader to boot my system menu and it just booted back into priiloaders menu and I know ios36 is patched and working for I use it to boot into my system menu with preloader v.3.--Sambena 14:28, 10 November 2009 (UTC)
why the hell are you using ios 36 for system menu 4.0... anyway, i have really no idea what you did. if you install priiloader(when system menu wad was installed which is pointless as the installer can uninstall priiloader itself!) does it say priiloader was detected? if so, you fucked your system menu (how, i have NO idea). as you can still boot the wii i recommend you recover a bootmii backup and try again.

unstalling priiloader

ok im testing priiloader to see if it install good and it did so i did try to unstall it and boom it on me wii still and i was like 0_0 so is it a bug??? and i do got bootmii so im good 0_0 is it a bug? —Preceding unsigned comment added by Wiisonic (talkcontribs) 04:17, 26 November 2009 (UTC)

your not even telling me what actually happens so how the hell should i know--DacoTaco 05:00, 27 November 2009 (UTC)

Unable to AutoBoot into System Menu When SD is Inserted

When my SD card is inserted, priiloader won't autoboot to the System Menu. Starting the Wii with no card inserted autoboots perfectly. I have it set to use System Menu IOS, if that makes any difference. Autoboot to HBC works fine. Haven't had a chance to test autobooting to installed .dol.--Qwertymodo 06:10, 17 December 2009 (UTC)

its being taken care off. it has to do with hacks :) --DacoTaco 15:34, 17 December 2009 (UTC)
Good to hear. Glad to see active development on this project. If it makes any difference, it fails to autoload with a card inserted regardless of whether or not the hacks.ini file is on the card.--Qwertymodo 10:33, 18 December 2009 (UTC)

Before I install...

Does it matter what IOS has the Trucha Bug? I have System Menu 4.2U and I used Trucha Bug Restorer Mod to install it.--Hunterm 03:21, 20 December 2009 (UTC)

yes, it has to be the IOS that is used by the installer. if you use Homebrew channel to load the installer this will be IOS36.note that you can also use 249 (cios) ( see on screen instructions)--DacoTaco 08:57, 20 December 2009 (UTC)
I have installed cIOS 249, so I just hold down B while installing so I can use 249! AWESOME!--Hunterm 20:29, 20 December 2009 (UTC)

Do I have to unnistall Preloader? If so, how? I have both Preloader and Bootmii.--Joaorbezerra 18:44, 21 January 2010 (UTC)

no priiloader can overwrite preloader. if you do wanna uninstall preloader first you can do so by reinstalling system menu wad --DacoTaco 20:34, 21 January 2010 (UTC)

Help!

How do I install this? Do I go to the SD Card Menu on the Wii Menu, or do I install it thru the HBC? Help me! I have 4.2 =( --jrcolonial98 —Preceding undated comment added 13:05, 1 January 2010 (UTC).

TBH, if you don't know that I don't think you should be installing this. This is quite a dangerous app which modifies the way your Wii functions. You should do plenty of research to make sure you know what it does and why/if you need it. --SifJar 14:15, 1 January 2010 (UTC)
Oh, I figured it out now. The only IOS with fakesigning was 36 so I loaded it thru the HBC and now it works perfectly. --jrcolonial98 {subst:undated|15:46, 30 January 2010 (UTC)}}

IOS Stub detection

I see that you you use the revision number to verify that an IOS is a stub, like i told in the ios history page, but it cannot detect "fake" stub, which are old ios non stub but with the revision changed to one another. Like in pimp my wii, where i use old revision of ios60, and change it to the latest revision, in order to prevent the overwriting when doing an update--Attila 00:17, 3 January 2010 (UTC) I suggest you to read the tmd and calculate the total size of the title with each contents size, and if the total is less than 200000, it is a stub !--Attila 00:33, 3 January 2010 (UTC)

True, and in the end i could readd my old checks ( checking tmd size (592 means stub...Except for ios 21) and/or the contents (stubs have 1 of their own and 2 shared. the others do not) ) but since this works with not modified IOS' (and even wankers CIOS 250) i think ill keep it like this and add the content checking since quite a few ppl use pimp my wii and i dont want more noobs shouting in my ears... --DacoTaco 00:42, 3 January 2010 (UTC)

questions from Bertm

I just put my hands on a 4.2u (LU65) that was messed with but I don't know what was done to it. When I turn it up the following menu appears on the screen: System Menu, Home Brew Channel, Bootme IOS, Installed File, Load/instal file, System menu hack, Settings,

IOS v70, System Menu v481 Priloader v0.3 (r41M), Priiloader is a mod of Preloader 0.30,

And it hangs there because I cannot sync any wiimote to the console. Is there a different controller that doesn't need syncing? Is there a way to get out of that situation? Any help would be appreciated. Thanks. Bertm 15:07, 11 February 2010 (UTC) Bertm

and that is why i hate unofficial releases. ow well, use a gamecube controller to move around in the menu. starting official 0.3 (rev47 or 48) you could press reset to boot sys menu but since this is a unofficial release thats not possible. gamecube controller is your cheapest way to go —Preceding unsigned comment added by DacoTaco (talkcontribs) 23:44, 13 February 2010 (UTC)
DacoTaco, as you suggested, the GC controller is able to navigate through the Priiloader, however there is not much I can do so far.
Here are the results I get from each option.
System Menu:
Failed to load System Menu
Homebrew Channel:
Upside down, displays apps from the APPS folder but doesn't seem to answer to the GC controller
Bootmii IOS:
Error booting Bootmii IOS (might not be installed???)
Installed file:
Runs whichever .dol I install in the "Load/Install File" option
Load/Install File:
Installs any .dol file residing on the SD root but hangs most of the time if I try to just load the same file
System Menu Hacks:
Everything is disabled for now
Settings:
Autoboot = System Menu
Return to = System Menu
Shutdown to = Off
Stop Disk = On
Light slot error = Off
Ignore standby setup = Off
Background color = White
Use System Menu IOS = On
When I try to re-install the HBC with boot.elf and private folder on the root of SD it opens the first warning screen and doesn't respond to the GC controller.
When I install "Wad Manager 1.5" dol on the SD root it opens the first warning screen and doesn't respond to the GC controller.
When I install the "Sign Check" dol on the SD root it works properly until it reaches IOS31 rev 3349 and it hangs there.
When I install "Dop-IOS Mod 11.5" dol on the SD root it seems to work with the GC controller.
When I hit the "Scan the Wii's Internals" it tells me that 25 IOS are safe to test but it hangs after the 18th, (IOS 31) just like "Sign Check" (It sees 250, 223, 222, 70, 61, 60, 57, 56, 55, 53, 50, 38, 37, 36, 35, 34, 33, 31 and they are all Fakesign)
Questions:
1) Should I do anything about the IOS lower than 31 since I can't list them?
2) How can I de-install Bootmii to make sure it does not interfere with the System Menu?
3) What would be the best way for me to re-install the HBC?
4) Should I use "Dop-IOS Mod 11.5" to re-install the 4.2 System Menu since I read that this would de-install Priiloader, I might end up with a full brick?
Thanks in advance, your suggestions will be greatly appreciated. --Bertm 03:54, 15 February 2010 (UTC)Bertm
Priiloader and Dop-IOS Mod v12 Beta5 saved my Wii.
1) Used Dop_IOS Mod v12 Beta5 to:
a) Remove Stub IOS30 which was preventing Syscheck to complete.
b) Re-install IOS70 with Fakesign, etc.
c) Re-install System Menu 4.2 while preserving Priloader (this new option is great)!
2) Rebooted
3) Re-sync Wiimote (finally)
4) Cleaned up all the junk channels that were installed by previous owner, including upside down HBC.
5) Re-installed stub IOS30
6) Virginized all non-stub IOS below 70
7) Updated Priiloader to v48
8) Started fresh install
I don't remember reading this anywhere, but while fighting with all this I found out that the upside down HBC was created by enabling Fakesign, etc on the IOS used by HBC. When you remove the Fakesign it comes back to normal.
Thanks all!!!
Bertm 19:07, 19 February 2010 (UTC)

Changelog needs update?

How exactly does the changelog need updating? --Dialexio 05:02, 1 August 2010 (UTC)