From WiiBrew
Jump to navigation Jump to search

Thanks for this :) Works fine with monkey1 and indy3 in fmtowns versions.

Thaks for the app guys !!!, it works awesomely, i'm sure a lot of people have been waiting for something like this for a long time.


Is posible to add usb keyboard support? Some games need more keys & buttons (example: Indiana Jones and the last Crusade).

when libogc has keyboard support i'll add it dhewg 15:39, 1 June 2008 (PDT)
Would you at least be able to assign the 8 Keypad directions to the 8 directions of the nunchuck or secondary analog stick of the GameCube or classic controller so that people can play the Indiana Jones games?
that would be specific to indy3. there are more games supported by scummvm that require additional buttons. there is a GSoC project dealing with this going on, that should eventually fix this and more issues. also, you can use the cursor for the boxing fights for now. dhewg 19:12, 7 June 2008 (CEST)

That would work for Fate of Atlantis, but there doesn't seem to be a fight cursor in Indy3...I suppose it would be a hassle to assign key functions just for one game, but 2 other games that require the numeric keys to function are Ween and Bargon Attack which require it for the copy protection and Bargon Attack also requires you to press F1 to start. There are enough keys on the nunchuck for all of these functions if it would be possible to assign them. Does libogc support the nunchuck?

USB Mass Storage devices

Is support for loading the games from usb mass storage devices planned for future versions? broody 17 Aug. 2008

Bug reports

Gobliins 2 in rev 20080603005132

  • Saving to an already occupied slot does not overwrite the previous save.
  • Saving to slot 3 does not produce a usable savegame at all (sometimes empty, sometimes garbage)
  • Objects get moved around the screen, e.g. the "Big Key" in the Wizard's house moves to screentop after been thrown down from the coockoo clock with the stone (reproducable), headless dog, missing chicken, random stone in the "Giant" screen (after loading a savegame)
  • Generally, saving and loading seems to shake the game pretty hard and is also very hit and miss
  • Aforementioned problems don't happen w/ daily build 20080603 win32 build

Drmr 19:44, 3 June 2008 (PDT)

the savegame issue is resolved in the latest version, but no clue so far on the gobliins gfx glitches. dhewg 19:12, 7 June 2008 (CEST)

Saving in rev 32506

My Sam & Max savegames made in previous builds no longer appear when I try to load them in this version. Said saves were in the /scummvm/ directory of my SD card (from its root directory), and were samnmax.s00 and samnmax.s01, both around 33.9KB in size (roughly). When I tried to make new saves in this version, they wrote to /apps/scummvm/ (rather than just /scummvm/), I have samnmax.s00 and .s02 (expected; I was trying to save to Slot 2 first rather than Slot 1), at 26.5KB and 26.8KB respectively. When I try to load the Slot 2 savefile, it shows a pure-black screen for its preview image, and says "Invalid Savegame" in its title, along with similar messages for its date, playtime, etc. box.

Notably, my 33.9KB-size saves are a little further into the game than the 25KB ones, but not by all that much; I picked up a few items from the start of the game, is all. The 25KB saves represent me trying to save as soon as the intro sequence ended.

I don't know if it matters, but in case it does, I am using the following equipment: American/NTSC Wii, Homebrew Channel installed to Wii menu, front SD card (1 gigabyte, works fine with most programs in terms of read-time, etc.), with Sam & Max CD 'talkie' version installed in /apps/scummvm/samnmax/samnmax/ (Yes, that is a little weird, I know. But it worked fine in previous builds). This is the first time I've had this issue. GespenstM 1:12 AM (CST), June 3, 2008

yes, as i mentioned on the Changelog and the READMII, i moved the paths around to resolve some issues. do not place your games under /apps/scummvm, use eg. /summvmgames or /scumm/games. savegames are per default in /apps/scummvm, you can create eg. /scummvm/saves and point scummvm to that folder in the main options screen if you like. make sure the "theme" or "extra" path does not point to a folder where you placed your games (incl. subfolders). you can move your old savegames from /scummvm to /apps/scummvm and remove the old folder afterwards. i also suggest to not reuse your old scummvm.ini dhewg 01:26, 3 June 2008 (PDT)

- First off, I owe you an apology even as I reassert there may be a genuine bug here. I need to admit I missed that line in the Readmii (I did read it, but missed that part), so I'm sorry about that. I've corrected the paths since then, and the 'bug' (user error) has taken on new behavior (apparently a genuine bug). There are three interesting parts to this.

  1. 1, Upon loading one of my saves, I began having a reproducible, patterned series of Invalid Savegame creation. Specifically, writing to an odd numbered slot (1, 3, 5, etc.) worked fine. Saving to even-numbered (2, 4, 6, etc.) produced Invalid Savegame. But when I quit out of ScummVM and reloaded from Homebrew Channel, these Invalid Savegames then became perfectly normal saves, that I could load much as an end-user would expect. No problems at all that I saw!
  1. 2, My autosave doesn't seem to write as often as it should if I look at it from the Load/Save menu while playing. But if I quit out of ScummVM and go back to the Homebrew Channel, then reload ScummVM, the autosave does indeed reflect a more current point in my game. When I loaded from my autosave after reloading ScummVM, I encountered item #3 below.
  1. 3, After making new saves upon loading my autosave, ALL save slots produced "Invalid Savegame", regardless of slot number. Quitting out of ScummVM and reloading it caused these to also become valid, loadable savegame files however. Very odd.

So there does indeed seem to be a genuine bug here despite my initial mistake. I'm going to make backups of these savefiles in case you need them, then I'm going to resume normal play since it seems to work with these 'reload ScummVM' workarounds. GespenstM 4:56 AM (CST), June 3, 2008

fixed in the latest build. dhewg 19:12, 7 June 2008 (CEST)

Auto-save/Saving in general

My copy of ScummVM was set to auto-save games every five minutes. Every five minutes, my game would halt, with a litte errer message on the screen, stating a failure in saving the game. The same thing happens when trying to save games as well. Any fixes coming soon, or am I doing something wrong in the paths or something? -Yaanu 15:02, 31 May 2008 (PDT)

verify that the savegame path in the scummvm option menu is correct dhewg 15:39, 1 June 2008 (PDT)

Simon The Sorcerer (DOS CD Version)

Seems to load OK, only played it for 5 minutes. All we need is some way to implement shortcuts for quitting the game when asked for confirmation ("y" and "n" for english, another ones for other languages), also nedding a "t" key to activate subtitules (I believe it was this one). Voices OK, Music OK, Speech OK.


i'll look into it, but i think that all options are availabe from the scummvm menu, which is working with the gc pad. dhewg 09:24, 21 April 2008 (PDT)

The non Scumm games (as Simon the sorcer 1 and 2, all Revolution games, FOTAQ etc...) does'nt use the ScummVM standard menu.

added"y" and "n" to the dpad in rev 32506. dhewg 16:49, 2 June 2008 (PDT)

a problem with filenames

There is a strange bug with ripped CD audio tracks from CD Versions. I had Zak McKracken (FM Towns), Loom (FM Towns) and Indiana Jones 3 (FM Towns) and Monkey Island (CD-ROM) installed but ScummVM used in all 4 games the audio tracks from Loom. After deleting Loom from the SD Card, all remaining 3 games used the tracks from Zak McKracken and so on. My guess is that the ScummVM uses the first audio files it can find and not the ones in their folder. I dont know if ScummVM simply misses the folder and use the first folder it finds instead of the right one or if it grabs the first track with the right name it finds, ending on bad formated SD cards in a funny mixed soundtrack of multiple games.

-- 15:37, 10 May 2008 (PDT)

Ok, i did some testing and the problem there is that ScummVM loads ANY file with the right name it first finds. So for example, Indiana Jones 4 uses a compressed monster.sog for speech. This works fine as long as no other Scumm Game uses also a monster.sog (for example Sam and Max does this). In the case of the monster.sog, its not so problematic because the game that loads the wrong monster.sog will just have no speech but will sill run but this problem is a big problem at games that uses the old filename system with *.LFL (ScummEngine 1-4, mostly used in the disk era) So Maniac Mainson and Loom (Disk Version) together on a SD Disk do not work. One of these two games will most likely crash at start while the other game will work just fine and because of the defragmentation on the SD its very likely that the working game will crash sometime later during a room change because game A tries to use a LFL-file from game B. -- 16:42, 10 May 2008 (PDT)
please try rev 32506. remove the old "/scummvm" folder on you sd card, the runtime data is now in "/apps/scummvm" too. this should fix the problem. dhewg 16:49, 2 June 2008 (PDT)
The problem is still here
follow my steps on the above "Saving in rev 32506", it is fixed. dhewg 19:12, 7 June 2008 (CEST)
It works like a charm, thank you! --aculotarpa 19:45, 7 June 2008 (CEST)

Monkey Island CD Version

I have Monkey Island, the CD version with icons rather than text for items. I copied the folders (MONKEY1 and MONKEY2) onto my SD Card, and sound with Monkey Island 2 works perfectly, but with Monkey Island 1, I don't get any music, only sound effects. Any idea? 06:24, 25 May 2008 (PDT)

see above, i think this is related. dhewg 16:49, 2 June 2008 (PDT)

Goblins Quest 3

There are some scrolling issues , they seem to be related to the pointer as it is very sticky, and it seems to unable to point far enough to the left part of the screen , making it unable to scroll left at all(or almost). Its also very hard to quit, again it seems the cursor doesn't go far enough to trigger the pull-down menu. There's a zone all around the screen where the cursor seems to stick. It also seemed to be a bit better in test 2 version. I used the version included with homebrew channel. Roamin 16:43, 28 May 2008 (PDT)

fixed in rev 32506. dhewg 16:49, 2 June 2008 (PDT)

Sam & Max

-It's usually very difficult to get out of the inventary screen. (Note: This might be related to the scrolling issue with Gobliins 3)

fixed in rev 32506. dhewg 16:49, 2 June 2008 (PDT)

-It's impossible to get out of the highway minigame.

why's that? dhewg 17:18, 2 June 2008 (PDT)

- Additional info on the above unsigned bug report... You can't get out of ANY minigame. This is because you're supposed to press 'Q' on your keyboard to do that, if I remember correctly. That or ESC, though I think it was specifically Q. For lack of keyboard support at this time, the workaround may end up having to be "Don't play minigames at this time"? GespenstM

yes, additional buttons are an issue on all games. check my reply on top ("Keyboard"). dhewg 19:12, 7 June 2008 (CEST)


-The aspect ratio is wrong, specially noticeable in NES Maniac Mansion but also in many other games like Sam & Max (where everything looks a bit taller than it should). It should be possible to stretch the display and fill the screen, so it would look more accurate in all the games.

i'll look into it, thanks for the report. dhewg 16:49, 2 June 2008 (PDT)


-When the screen is supposed to be shaking, it doesn't. This would apply to (at least) Sam & Max and DOTT.

yes, screen shaking is currently not implemented. i'm going to add that feature at some point. dhewg 16:49, 2 June 2008 (PDT)

-MT-32 emulation seems to be missing some instruments (very noticeable at the beginning of Sam & Max).

does this also happen on eg. a nightly win32 build of scummvm? dhewg 16:49, 2 June 2008 (PDT)
-I think so.
then its not wii port specific, please report it on the scummvm bug tracker. dhewg 19:12, 7 June 2008 (CEST)

Broken Sword

When I launch the game, it loads for a while, then exit to HBChannel. ScummVM rev 32475 20080602000000, Broken Sword italian, movies in dxa format, speech music and movies audio in ogg format.

delete scummvm.ini and readd your games, this should fix it. dhewg 19:12, 7 June 2008 (CEST)
Done, the problem is still here. ScummVM rev 32565, 20080605233742. --aculotarpa 19:47, 7 June 2008 (CEST)
hm, please try the vanilla audio file or another audio compression like mp3 or flac. if this still doesnt fix it, please use the scummvm wii forum, this page is getting a mess :\ and for the record: english version+flac=no probems. dhewg 20:44, 7 June 2008 (CEST)

Monkey Island 3

just for interest, are there more reserves to improve the performance of MI3 further? (great work!)

credits go to svpe for improving the read performace. this is a libfat issue and is out of scope for this port. i'll guess libfat will eventually gain more speed boosts. dhewg 19:12, 7 June 2008 (CEST)
You might want to try compressing the files, that has worked for me. Azeazezar

Broken Sword

The game starts, but there is no Intro (only sound). Then i can play normal but i can´t save. (i think further cutscenes will not work too) (german version, cutscenes pack from

works for me, use the latest version and reorder your paths on sd like i mentioned above. dhewg 19:12, 7 June 2008 (CEST)

Indiana Jones and the Fate of Atlantis

The speech doesn't work (in cutscenes or in the game). I've tried it on Windows version and speech works fine. I have the latest version (rev 32565).

My games are all in \apps\XXXX and scummvm is in apps\scummvm

Speech works fine in Beneath a Steel Sky and Flight of the Amazon Queen.



Could you please release the source for this? I'd like to build it myself. (Actually you will have to release it as per GPL...)

i'm currently working on getting this port included in the official scummvm svn. i hope this happens soon dhewg 16:49, 2 June 2008 (PDT)
the source is now included in the official svn :) dhewg 19:12, 7 June 2008 (CEST)

DVD drive access

When I load ScummVM, I usually dont have a disk in the drive. However, I had Zelda in, and it wouldn't load. I had to shutdown the Wii and turn it back on. After removing the disk, it worked. Why exactly, and can it be fixed? Also, is it possible to insert the real CD-Rom game in and play it? --Atariangamer 19:28, 5 November 2008 (UTC)

No the Wii can only read DVDs, not CDs. CDs hold about 500MB while DVDs hold up to 8.54. Thus you need a special laser for the task, as they are different "formats" in this way. The problem with a disk being in the drive is most likely fixable. Often it is data going where it isn't supposed to. This was the case for an emulator, where you would have to take out the GC controllers or you would get a stack dump. If you like the game on a CD, you are in luck, as CDs can easily be ripped and put on an SD card, though I don't know if it should be an ISO, the data files themselves, or if you nee special software. EDIT I forgot my signature--retrotails 15:32, 2 April 2009 (UTC)

Download Link

Hi, 2 things, 1.) shouldnt the download link to their site. sence they host/make the wii version? 2.) and they realesed version 1.0.0 today.. Some one should update the link--Hatredg0d 23:19, 17 November 2009 (UTC) EDIT, ok i just updated link/ version number myself.--Hatredg0d 23:23, 17 November 2009 (UTC)