Talk:Homebrew Sorter

From WiiBrew
Jump to navigation Jump to search


Sorry to bug you guys, but when I open the homebrew sorter, it just freezes at "loading" and I'd really like to use this app. :( Shadowtroop 14:12, 23 December 2009 (UTC)

Can you try and see if it mounts anything? --Teknecal 12:51, 23 December 2009 (UTC)

Nope, same thing. But it did say something about "Unable to find settings file" I downloaded it from the homebrew browser. Was it supposed to come with one? Shadowtroop 14:12, 23 December 2009 (UTC)

No it doesn't need to come with one. So which device of yours was mounted? SD or USB? Try this one (it won't go into the GUI and will exit by itself): It should print out "Going to read apps", then list apps like "App = ftpii", then say "Finished reading apps, time to sort" then "Reading Homebrew List", etc. Let me know exactly what it all prints out or take a picture of it, thanks. --Teknecal 06:25, 24 December 2009 (UTC)

Ok, what happens is that it goes normally, says settings file not found, then "EXCEPTION DSI OCCURRED". Also, now that I think about it, have a lot of folders in /apps that have no boot.dol. Is that screwing it up? Shadowtroop 20:18, 24 December 2009 (UTC)

I'm having the same problem, but it did work at first. Then I decided to abandon Catagorii and dump all my various app folders into apps, and that is when this problem started. I don't have folders without a boot.dol, but I do have a lot of app folders. I will try the debug program and post the results.--Donsch 15:51, 25 December 2009 (UTC)

OK, the debug program helped, it was getting stuck on komopong_wii, I have no idea why, but removing the folder let it finish the list. Thanks for the debug util, the regular program seems to be working again. When I put the boot.dol from komopong_wii back in the folder, Homebrew Sorter locked up again, so definitely confirmed the source of the problem, I also confirmed that the pong game works fine. --Donsch 16:13, 25 December 2009 (UTC)

So it's probably one of my hundreds of apps. Dammit. --Shadowtroop 21:58, 25 December 2009 (UTC)

Thanks for testing it out. I think I found the problem, was in parsing the meta xml. Could you guys try: --Teknecal 03:34, 26 December 2009 (UTC)
Also v0.2 has been released now. --Teknecal 01:23, 28 December 2009 (UTC)

I just installed v.2 and it seemed to fix the directory problem at first, but now every homebrew app presents me with a black screen. Running homebrew sorter was the last successful thing that I did, but now no homebrew works. I get the progress bar showing the app loading, but then nothing but black. I have a backup of the NAND, but not ready to resort to that yet.--Donsch 18:01, 1 January 2010 (UTC)

UPDATE: I switched SD cards and homebrew still works, so something must have happened to the SD card with homebrew sorter installed on it. At least the Wii NAND seems to be unaffected. Browsing the file structure of the corrupted SD card does not give any clues, all looks good, so it is still a mystery. I'll post again if I discover what happened or get it working again.--Donsch 00:41, 2 January 2010 (UTC)
Ok, got Homebrew working again, backed up the SD card giving me trouble, reformated it, and reloaded it. I ran HBC, FTPii, and Homebrew Sorter, (these didn't work before) and all seems fine again. Who knows what happened, still a mystery. I love the Homebrew sorter program, and have some ideas for it if the author is interested. --Donsch 01:41, 2 January 2010 (UTC)

I have had the same experience with this app running on my SD card. "Looked on >>Loading" Currently trying V0.2. Maybe what needs to be included with the ...Loading Message is what folder is currently being scanned. That way a user would know what needs attention.--capple123 02:54, 6 January 2010 (UTC)

Ok, version 0.3 is out and this should hopefully all be fixed. It now shows which directory it's parsing. --Teknecal 02:02, 28 March 2010 (UTC)

I'm trying out v.03 and it is crashing somewhere during load, it has been run once and renamed lots of dols, but now it crashes, and it goes by to quickly to see which directory is failing, so I can't even say if it's the same one each time. Is there a current debug build? --CalcMan 05:29, 10 August 2010 (UTC)

I've been working on v0.4 for some time now, I believe it's almost ready for release, I'm just waiting to hear back from a user testing it. Please give it a go: --Teknecal 08:32, 10 August 2010 (UTC)

Feature Wish List

It would be great when you go into Settings to be able to see each category apps are assigned too. One way to do this would be to color code the category names, and show app names in matching color. Another way would be to have a little icon of the first letter of each category (since they happen to be different) between the category names and the app names. Thanks for making this app. --Donsch 14:20, 2 January 2010 (UTC)

Here is an idea for a color coding the catagories. See my page --Donsch 16:36, 3 January 2010 (UTC)

Homebrew Sorter Downloader

Considering how useful this program is, it might be good idea for my app that would download it, and then extract it. Would you be ok with letting me do this? (Yes I also did this with HBB) —Preceding unsigned comment added by Hunterm (talkcontribs) 05:08, 10 January 2010 (UTC)

Yep that's fine too :) --Teknecal 05:18, 10 January 2010 (UTC)


How would someone uninstall this without ruining anything? Thanks. --Jsovey 08:37, 10 January 2010 (UTC)

When booting, select the "All" category, make sure all your apps are displayed in HBC and then you can remove the homebrew_sorter folder. --Teknecal 09:12, 10 January 2010 (UTC)

I installed hbs from homebrew browser and ran it. None of my apps showed and rather then play around or even hit "all" I just deleted hbs. Since then my homebrew channel has been useless. I have tried formatting my sd card, uninstalling bootmii and homebrew channel and doing a complete fresh install of everything. But much to my dismay the homebrew channel is still blank after a fresh install. how do I undo what hbs did? Syco78 01:30, 13 September 2010 (CEST)syco78 9/12/10

You can also run to restore all applications to HBC again. --Teknecal 14:51, 13 September 2010 (CEST)