Talk:List of Working Bluetooth Devices

From WiiBrew
Jump to navigation Jump to search

Does anybody have a good brick-and-mortar source for a Wiimote-compatible adapter? I wanted to get something now, not wait for shipping...

"Kingston" 33348 working?

--- WIDCOMM with on VISTA Problems: I installed this stack on vista and the WiiMote works great after being installed. However, whenever I remove the Kensington adapter and then reinsert it (or stopping it and restarting it), it freezes up windows. After re-installing WIDCOMM, the same problem. It works great until I remove the adapter.

I installed WIDCOMM to test. Now I can start the adapter without freezing Vista, but the WiiMote does not work.

So does anyone have any idea why the WIDCOMM would freeze windows when I insert the Kensington adapter and how to get around that problem? - Rick ---

--- To Rick: I have the same problem as you. + Kensington 33348 + Vista = Freezing. So here is my solution which works for me:

1. plug your Bluetooth-Adapter into computer and goto device manager. Then reinstall Kensington and make sure click on the checkbox in the dialogwindow below to remove the driver from your computer and now move your Bluetooth-Adpater from the Computer.
2. goto c:->windows->inf. Then rename or move the files bth.inf and bth.pnf to avoid installation of Microsoft bluetooth stack.
3. uninstall the widcomm software and restart computer. Then goto c:->program files delete the widcomm folder, if it exists.
4. download Kensington widcomm Software (you might need to register to get the download) from here:
5. Now do not plug your Adapter. click on Setup to install, by the way click on cancel to let windows warning you the driver signification everytime and when the windows comes just click install driver anyway, you might click it for severaltimes. If the dialog with the information about cant find bluetooth... comes, you should plug your Adapter now into the computer and click ok. Then Just Let It to be finished.
6. If everything goes good. Then just try plug and move the Adapter many times to make sure it wont be freezing anymore.

It works for me !!! --- fifaguys

Kensington has an anonymous FTP site that allows to you download the version of the WIDCOMM stack. Simply get them from

I own the kensington model 33348. It worked just great with XP. I just upgraded to vista and can not get it to work. Kensington help isn't very helpful. Anyone out there get it to work with vista? ~J

Whoever added this line: "Kingston Bluetooth dongle (model 33348) using WIDCOMM stack" Could you tell me: a) did you actually mean KENSINGTON 33348?, and b) did you do anything special to get it working? I have the Kensington 33348 and tentatively added it to the Not Working list, because I get the same problem the user of the 33085CA had -- you click "Skip Pairing" and nothing happens. If you happen to read this page, could you elaborate? -James (To James) I has the same problem where skip pairing did not work. I did the setup and it fixed it, thank you!)

Answering my own question: with the WIDCOMM, if you try to connect to a device in My Bluetooth Places by double-clicking its icon after search, the Skip Pairing button does not work. You must start the Bluetooth Setup Wizard (in the Explorer Bar), discover the controller, then click Skip Pairing. -James

  • I have tried this with the Kensington adapter.. I got to the point where it was connected, and had the "green arrows" on the icon. But the 4 lights would not ever stop flashing (wiimote stuck in Discovery Mode?), and no programs were able to communicate with the device (i.e. WiinRemote got "Error 5: Access Denied). Any ideas? -- Jozxyqk 04:44, 15 January 2007 (PST) Self-update: Apparently, I was using "5.0.*" version of the stack, and that doesn't work with Wiimote. But downgrading to the 4.0 version works like a charm!
  • TCS - The link to Kensington drivers no longer works. The driver CD that came with my 33348 had the WIDCOMM drivers on it though. When I first installed the drivers on WinXP sp02 I did so from the AutoStart CD screen. After driver installation I paired my device (use wizard) but communication was only one way. Neither GlovePie nor WiinRemote would respond to wiimote button presses. I then installed the updated drivers listed on Kensington's website (upgrades to WIDCOMM 5.0.* stack) and the wiimote did not work at all. I then uninstalled those drivers and reinstalled the drivers. However, this time I installed by running setup.exe directly from the folder on the cd. Now everything is working fine.

I have version and, as much as I have tried, cannot seem to remove the drivers to downgrade to The setup for 4.0.1 tells me there is a better version installed and i can't manually delete the driver. :\ -Dylan


1. Uninstall 5.1 software. Restart. 2. Redownload 3. Unzip contents. 4. Install.

Make sure you are not replacing the 4.0.1 license.dat with the 5.0 one.

- Matt D

Made-in-China brand. "BT2.0" VID=0A12 (Cambridge Silicon Radio, Ltd) PID=0001. Comes with Extended Systems XTNDConnect Blue Manager. Driver: Windigo Systems, PBTUSB02C2 Bluetooth, csrbc01.sys

I have the above no-name-brand CSR usb dongle. It came with bluesoleil drivers (in chinese/manadarin most probably) which didn't work for me, it found the device but glovePIE and WiinRemote would not work at all. I then tried the MS bluetooth stack which was a bit better; button presses and LEDs were working. Finally, after uninstalling and removing the other stacks, I tried version 4.20.08 of the Toshiba stack for WinXP ( ) which you can use for 30 days, and it now works perfectly, including motion and rumble. I'm off to try the pointer functionality with my modified sensor bar!

Ore wa setei Souzar!!

WIDCOMM drivers seem to be the only drivers that work for the 33348 in XP that I know of. Version 5 will hang on skip Pairing as mentioned above. You must go into control panel and uninstall version 5. Also, there is a 'license.dat' file that is used to verify the serial number of the device. So you must make sure you have not only WIDCOMM firmware, but for the correct device as well. If you try to use a different .dat file from a different version, it knows what it is and will give an error message. My problem came when I wanted to install the dongle on a AMD64 system running Windows x64. Version 5 has a 64 bit driver that works, but it still hangs. Though the CPU can run 32 bit apps natively, version 4 fails to put the 'bluetooth places' icon on the desktop and crashes explorer. Though the install finishes, the bluetooth places is non existent and hence, you cannot run the device wizard. WIDCOMM does have a version six for Vista and Vista x64, but I did not bother downloading. The patch can be found on the kensington driver site. On a side note, the 'bluetooth places' icon on the desktop is unmovable. Its not a shortcut nor an normal exectuable. It cannot be deleted unless the firmware is uninstalled from the control panel.(sorry if I did this wrong, it seemed important) /Thomas

AHHH!! I'm having the same problems (with the Kensington), but I'm stuck with the version 5.x of the stack. could someone please put a link to version 4 somewhere? i can't find it anywhere online... :(

How about this:

To delete the WIDCOMM desktop icon remove this entry in regedit and restart: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{6af09ec9-b429-11d4-a1fb-0090960218cb}

Actually, no need to restart, just refresh the desktop.

Thanks for the instructions, but I had a different name at the end. If you don't have '6a...', just look for the key in that folder (...\Namespace) with 'My Bluetooth Places' in it.


Hey, I am using the version 4 widcomm stack, and said Kingston dongle. I have had my wiimote working in the past perfectly, but after a few weeks of no use, I decided to connect it to mess around a bit, but now when I get to select services, nothing shows up and it doesn't connect. This particular wiimote hasn't been connected to the wii in awhile, could that be the problem?

kensington ** windows xp worked fine here version 33348 with widcomm version 4, i was able to use wiimote and glovepie perferctly , then after few hours , tried to connect agian , connected but not working , tried uninstall and install , upgrade and downgrade , nothing it is not working no more , only connects to my motorola k1 ( hassan )

The Kensington FTP server has vanished. Any good mirrors of the old drivers? Or am I stuck having to buy a different Bluetooth dongle? -Jack

which drivers (stacks) you use ?

  • Microsoft
  • Toshiba
  • Widcomm
  • IVT Bluesoleil

Billionton, fix your download links!

  • Looks like they fixed the links. --Yqbd 16:42, 11 January 2007 (PST)
  • Looks like it's broken. --Yqbd 20:28, 11 January 2007 (PST)

Billionton, Cambridge Silicon Radio, Hardware Ids USB\Vid_0a12&Pid_0001&Rev_0525, USB\Vid_0a12&Pid_0001

  • Did anyone get the Wiimote working with Billionton, Cambridge Silicon Radio, Hardware Ids USB\Vid_0a12&Pid_0001&Rev_0525, USB\Vid_0a12&Pid_0001 without bluesoleil? --Yqbd 16:43, 11 January 2007 (PST)

Anycom 'Blue 200/250' works

You can get the Anycom Blue 200/250 USB-Dongle to work under Win XP. Install the software that is delivered with the device and after that install the WIDCOMM stack from Kensington. You are able to connect the Wiimote to a Windows-PC and use (for example) GlovePie. It seems that you cannot save any settings, as the software does not remember the Wimmote and you have to register it new every time you want to use it. But maybe I just cannot find the settings in this less-than-usable software. ;oP Xanathon 06:36, 16 February 2007 (PST) Addition: Best way to get the Anycom work: Remove any driver for the dongle and any stack you have installed. Then install the stack provided by the above link. If you are told to insert your Bluetooth device don't do so and continue with stack installation until it's finished. After that plug in the dongle and point the hardware assistant to the CD delivered with the device so the driver can be found. That's it, you now have to find and connect the Wiimote in the Bluetooth-software. Should this be inserted in the main article? Xanathon 23:54, 4 April 2007 (PDT)

IOGear Model GBU221

  • IOGear Model GBU221 (NOT to be confused with GBU211) BT version 2.0 (GBU211 is version 1.2) using default MS stack, and will not connect to BlueSoleil. Works in GlovePIE 0.26 with the "TroubleShooter > Bluetooth Fix" menu. Works in MiiTransfer. Works under Linux. Uses same chipset as Wii's BT board (BCM2045)
  • GBU221 worked on one computer using Vista's BT drivers with RMX with one Wiimote, but then doesn't work on two other computers with Vista and XP with a different Wiimote. I'm wondering if it's the Wiimote. I'll have to try it out with the Wiimote that worked. --Yqbd 00:48, 11 March 2007 (PST)
  • Used GlovePIE Bluetooth Fix and GlovePIE is able to change the lights and make it rumble, but it's not getting the accelerometer and camera data.--Yqbd 00:48, 11 March 2007 (PST)
  • Installed GBU221 using the Broadcom driver from - connected and worked. Built my IR pen but was unable to get it to connect a second time. The first was by accident. The only way I can get it to connect is by following the Wiimote Tutorial, but just after skipping the pairing and waiting to press step 7 "Finish", I let the wiimote's lights go out. I have to hold 1 & 2 again and hit refresh, select the checkbox for the device, then click finish. Works each time if I do it this way. Note: I am only using this for the wiimote whiteboard so I don't know about buttons or rumble functionality.


Perhapse someone should test the Syba SD-U1BTC2-IS, I beleive it works with BlueSoleil... I am getting one (shipping sucks) and when it comes in I will test and add it if no one else has.

Edit, got it and added it. Works like a charm with the included drivers.

In order to get gbu211 to work properly you must let XP install the default drivers. Then install the latest version of Bluesoliel. Once installed, pair from Bluesoliel, then run GlovePie.... Trust me...gbu211 IS old...but bluetooth has not advanced that far.

ThinkPad Z60t

Under Kubuntu I cannot get the Wiimote connected. I press connect under 'configuration>input devices' but Wiimote does not stop blinking until I press disconnect again. Under Windows XP it does not even communicate as it always asks me for a PIN.

What is the best or most compatible dongle?

Is there a recognized easy to use/setup or better working brand? I am currently looking to buy one specifically to use my Wiimote with the computer and am looking for suggestions. Also it would help if there was prices on these (like the average retail price for each)

-- I agree that a recommended, fully compatible (hopefully with the MS Stacks) adapter section should be added.

Bluetooth Version?

I need to know what version of bluetooth the wiimote uses, as i am buying a dongle.

LogiLink's Micro Bluetooth Adapter

I want to mention that this one (image) worked pretty fine with its default drivers (page; the driver) on Windows Vista 32 bit. The connection doesn't fall out immediatelly, the Wii Remotes react swifter than with the default Windows drivers. 11:43, 2 July 2009 (UTC)

SOLVED: Skip pairing on latest WIDCOMM drivers

To skip the pairing screen on WIDCOMM 5.5, simply press alt+s. It works, trust me. This will solve most "incompatibility" issues people are having with connecting the Wiimote to the WIDCOMM stack. Agwellin 06:50, 13 June 2010 (UTC)

Mico Mini... thing

Does this one work?

PPA International: works with BlueSoleil (Windows 7)

Tested with "PPA Int'l USB Bluetooth v2.0 + EDR dongle". Didn't work with Windows 7 own bluetooth manager, but once installed Bluesoleil that came with the dongle, everything was fine. —Preceding unsigned comment added by Avtanski (talkcontribs) 21:35, 5 April 2012 (CEST)