Talk:NUS Downloader

From WiiBrew
Jump to navigation Jump to search


Attempting to download Wii titles results in a 404. DSi titles seem to download okay though... Kamek 22:37, 5 April 2009 (UTC)

When this error happens, it deletes all the folder. For example, if you download an old version and then any not-existent version, it deletes the folder. This will be fixed, right? Duhow
I should probably start a more detailed naming convention for folders, such as \[titleid]v[####]\ --WB3000 23:55, 8 April 2009 (UTC)

Could you specify some details such as Title ID / Version? Make sure both of them are legit, you can leave version empty for the latest one. --WB3000 22:56, 5 April 2009 (UTC)

Sorry, false alarm. Router settings were the trouble. Kamek 23:03, 5 April 2009 (UTC)

Had the same issue with this (404s downloading titles). It was the firewall settings. Check your firewalls if it doesn't work folks. Also, thanks for this program, cygwin and update downloader just didn't cut it.--Techboy 02:52, 6 April 2009 (UTC)

IOS file doesn't match dumped file from game disc

I downloaded IOS36 revision 1042 and compared it to my dumped IOS36-64-v1042.wad. IOS36-64-v1042.wad is bigger than the created one, because it has a duplicate of content 0( as trailer file included. And the certs and tik file differ, while the contents in the certs file just seems to have a different order. So my questions are:
1. Why is there the duplicate of content 0 as trailer in the official wad? Does anyone know, or might it be better to create own wads the same way?
2. What effect does the changed tik file have? Any suggestions why the file is different? --WiiPower 08:04, 6 April 2009 (UTC)

I based my packing code off of code by Crediar, as well as the WAD files documentation on this wiki. According to that, there is no duplication, and it would seemingly be ignored anyway according to TMD.

I don't knowingly edit the tickets, beyond sizing it down to 0x2A4.

If there are any concerns about the process, please by all means check the source code, or simply use a different packer you are comfortable with. --WB3000 22:12, 6 April 2009 (UTC)

I'm sorry, i should have expressed more clearly what i meant. I just wondered why nintendo has 2 different tik files for IOS36v1042 and why nintendo packed the duplicated file into their wads. Does nintendo this for a reason? Does this have any effect on any application using these wads? Do installed IOS with these wads differ? --WiiPower 12:53, 7 April 2009 (UTC)
I have the same files and when comparing, the data section starts at 0xD00 in both, so I don't know where any duplication is occurring. I've installed a Shop v16 WAD with no apparent side affects.
Update - I've taken a look at headers between the two IOS36 wads. The cert I am using is identical to the one used in the official WAD, except parts are reordered. This is interesting but does not affect the overall cert itself. Perhaps there are several variations in the order spread around.
I honestly don't see two ticket files. When chopping out the data section (0xD00) and beyond, and from the beginning to the end of the cert, I am left with only a single ticket in both. The initial chunk of difference in the tickets is the hash, which would make sense. The small changes in the ticket appear to be the ticket_id as well as...Amount of bought DLC contents? Ticket_ID is odd, perhaps it is randomly generated and simply varies from Nintendo's disc distro to NUS.
I realized I must have merged TMD and cert together when examining, although that wouldn't affect anything as both TMDs are the same. --WB3000 02:21, 8 April 2009 (UTC)


Looks like my idea cough on ;) --Dan11495 17:23, 8 April 2009 (UTC)

I think that it would be ideal to have all ID information in the Title Database page itself, rather than only a portion scattered around on this page. Sadly, the database is a bit cluttered, so for now I'll leave what is there but I'd like to eventually organize everything where it belongs. --WB3000 21:57, 8 April 2009 (UTC)

Title DB

Please add found titles to Title database instead and IOSs here IOS History Crediar 15:04, 10 April 2009 (UTC)

I've went ahead and merged everything to those pages. ;)


To run NUS downloader on Linux/mac you need to do this

1. Run terminal 2. Type CD (NusdownloaderPath) 3. Type Mono (name of Nusdownloader.exe)

You need Mono 2.2 or higher

NUS Deleted some folders on my desktop!

Not only did it delete 5 or 6 things off my desktop, It deleted certs, key.bin, readme, and the folder it was in. It killed like, 20000 famly photos. NEVER, EVER, EVER useing on my PC again. :-/ —Preceding unsigned comment added by Remadon (talkcontribs) 17:07, 17 May 2009

Honestly, I don't believe there's any way that could happen. The only thing deleted is the title ID directory upon a 404 of that Title. You could probably try some file undeletion software in the meantime. --WB3000 18:21, 17 May 2009 (UTC)
I've been looking into the issue. There is only one way this could happen: You entered nothing into either box. I've fixed the potential issue here, maybe I'll throw a v1.1a if necessary. --WB3000 21:21, 17 May 2009 (UTC)
Ouch, that's a pretty bad bug. I left you a message on your talk page on how you (or anyone else that may encounter this bug) can recover your data with Recuva. — Blooper (Talk) 22:16, 17 May 2009 (UTC)
Actually, the same thing happened to me. I just ran a System Restore Point and got everything back. It restored everything as if nothing happened. --SonicHyuga 23:24, 17 May 2009 (UTC)
OK, I've pushed v1.1a with the nothing-entered check. Hopefully this is the issue, since there's nothing else that would make this happen. --WB3000 23:52, 17 May 2009 (UTC)
Sorry about not signing the post, It was by me, My brother had everything backed up, so its not a big deal. Glad to hear the bug is fixed. Sorry for the User confusion,Yay! Bug is fixed! Just tryed it! --Remadon —Preceding undated comment added 03:52, 18 May 2009.

*nix Port?

It would be really cool if you could port this to Unix systems(Linux/Mac). A command app would be great and easy to do as it's just a downloader! RedChaos 17:07, 17 May 2009 (UTC)

I just found a CLI rewrite of my program today, though it's still C#. Perhaps it will compile with Mono, or at least have less issues doing so. --WB3000 18:22, 17 May 2009 (UTC)

Mismatch "Error" at Pack->WAD?

When I download some IOS, the NUSD says at packing the WAD "mismatch" Example: 00000000 wrote (0x1100);; 00000001 wrote (0x1140) (Mismatch) ;; 00000002 wrote (0x92c0) (Mismatch) ...

I compared with a packed file, downloaded with the 1.0 Version. They have the same Size, Bytes same too. So, what means that? (I tried several times, same "errors" in different IOS. —Preceding unsigned comment added by Boy2048 (talkcontribs) 14:58, 18 May 2009 (UTC)

Having a mismatch is OK. It basically relates to how some files are padded in order to allow AES encryption/decryption to work. Files not aligned to 16 bytes are padded with 0x00 bytes until this is achieved, and then encryption is done. However, the size stated in the TMD relates to the 'useful', before padded size. Having a mismatch simply means that TMD vs actual size differs, which is quite common.
As long as the download completed successfully, a mismatch isn't anything to worry about. --WB3000 20:53, 18 May 2009 (UTC)


When packing the sysmenu 3.4 wad I get the error mismatched. Is it still safe to install? TwoBladedKnight 09:57, 20 May 2009 (UTC)

See above question... --WB3000 20:37, 20 May 2009 (UTC)

Sorry... I probably should've read this page before jumping in >.< my bad... TwoBladedKnight 06:19, 21 May 2009 (UTC)


I cannot compile stuff, it seems to need another file when compiling.

       public Form1()

Erreur 1 Le nom 'InitializeComponent' n'existe pas dans le contexte actuel SourceCode.cs 34 13 Project2--Attila 17:01, 20 May 2009 (UTC)

I only gave the actual form code. This is all that's really modified from a standard C# GUI template. Source is included as more of a 'how-to' reference, not as a perfect, compiling collection of files. --WB3000 20:37, 20 May 2009 (UTC)
The Form is missing, so i must draw a new form to use your code.--Attila 18:21, 22 May 2009 (UTC)
Now the entire source code can be found on Google Code. (see main page). --WB3000 03:05, 11 June 2009 (UTC)
Thanks. In fact i wanted the source to add the ability to select "common" title id like for ios available on nus, and common channel (wiishop etc) without needing to do the translation IOS36 -> 0x24 -> 000100024 .. etc :) —Preceding unsigned comment added by Attila (talkcontribs) 12:06, 11 June 2009 (UTC)
Next version has a database feature, as you can probably see from the code. That's about as common as the IDs can get :P. —Preceding unsigned comment added by WB3000 (talkcontribs) 19:38, 13 June 2009 (UTC)


I've got to give you kudos for this app. Thanks to this excellent app I can have almost all system menus whenever I want! THANK YOU! TwoBladedKnight 10:38, 21 May 2009 (UTC)

Mac please?????

I would be ever so grateful if you would port this for mac as i have not one windows computer in my house. Yet i still need to use this application for (well what this app does) thanks very much --Flyguy 16:46, 21 July 2009 (UTC)

Please?--Flyguy 22:16, 9 August 2009 (UTC)

Won't close when finished in the command prompt

When I type something like this into the command promt

"NUS Downloader v1.2" -t 0000000100000009 -v 521 -s -local -close -p IOS9-64-v521.wad

it downloads and packs fine, but the process doesn't stop itself, it's taking up quite a bit of CPU so I'm not sure what it's doing?--594rk 22:03, 5 August 2009 (UTC)

I'm going to look into that, I haven't really tested much of the cli features, and it's becoming clear that they are not working as I had planned. --WB3000 15:55, 6 August 2009 (UTC)

Wrong filename for WAD

Filename for wad are exact but they are not for BC/SYSTEM Menu. They are like : System Menu-NUS-v193.wad instead of RVL-WiiSystemmenu-v193.wad Filename does not use databse if we click on pack wad AFTER selecting a title in the database. However, good app.--Attila 17:26, 7 August 2009 (UTC)

I've gone ahead and added both System Menu official naming, as well as database lookups for the filename during any change to the info (including checking the box after selection) ;) I'll throw it in the SVN, however it won't be official until 1.3. --WB3000 20:50, 7 August 2009 (UTC)
Ok thanx. By the way, mios is wrong too, it's RVL-mios-v5.wad and not MIOS-64-v5.wad--Attila 22:44, 7 August 2009 (UTC)
MIOS filename is wrong :)--Attila 13:30, 18 August 2009 (UTC)

key.bin file

where can i get the key.bin file??? Darklink 01:47, 13 August 2009 (UTC)

Well for starters it is also known sometimes as common-key.bin. Google is probably your best bet, or perhaps some other program might have it bundled. --WB3000 12:32, 13 August 2009 (UTC)
The WiiScrubber package has a file MakeKeyBin1.1.rar included which has a generator for both key files. Or you can go to and write your own key.bin file with an hexeditor. --WiiPower 15:44, 13 August 2009 (UTC)

Why doesn't key.bin come with this program? marcan said somewhere that you can't copyright keys. Link33 12:41, 13 August 2009 (UTC)

Marcan doesn't live in the United States, so he is unaffected by the DMCA. It was ineffective against the infamous 09 f9 11 02 key, though. --Dialexio 14:02, 18 August 2009 (UTC)

Hash Check: Fail

Hey I'm just wondering why I get failed hash checks. I am downloading System Menu 4.1U. Here is my log:

Starting NUS Download. Please be patient!
Grabbing tmd.449...
Grabbing cetk...
Key Type: Standard
Title Key: C8AB2B9EB0C09CA2C12F3E367C2E4745
Requires: IOS60
Content #: 9
Total Size: 22158026 bytes
Grabbing 0000007a... (64 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: 95BC91D71E7ACB236AD2207C6B12EDFB3E8482E3
    - You Have: 7FDF67BCC6BCC83F0A5E3289B12176BDF315CD2A
Grabbing 0000007b... (6399911 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: 2785EAFEC3F5DAFEF691E7154A9CB74B4528777B
    - You Have: AF9873F5518E4A07112474C0986BF825D62FB771
Grabbing 00000009... (4559887 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: F5DD17B3200DD4D6BE2B25B577C99E5F941B7324
    - You Have: 9C5766C6CF248C93DD91237EDC0B8C8222079AE7
Grabbing 0000000a... (2669044 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: 32B339CBBB507D502779259A7866995D030B1D88
    - You Have: 2E23F3847BCB7797EFCDB63741915D842DC93C2A
Grabbing 0000000b... (686468 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: 5F1BB7B02794B14E88B72269A3376D23051DAD1D
    - You Have: 187F960BA1B01194AB6CFEB00682D00AE96A2995
Grabbing 0000000c... (3649020 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: 4FAD97FD4A288C47E0587F3BBD292379F8709EB9
    - You Have: 5795329280C2334BFAC629115262D1FBCF5E6A25
Grabbing 00000059... (272512 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: 293D734260AC99F4D3DE75310A7D273466F6BE08
    - You Have: D6135EB605CA1C6ED12DD5C0AC66AB9BA675C2AB
Grabbing 0000005a... (53216 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: 534D2952FE2F664370D8364B9A0A0D1F55A05931
    - You Have: B629BD3D6BD75B6E12E6674747CDCBFC5434A2C4
Grabbing 0000007c... (3867904 bytes)
  - Decrypted:
  - Hash Check: Fail
    - True Hash: 947A3F929323F6C8B3515D8960E7427A7A3E9D87
    - You Have: 69A3B72CC857C432426598C830828DB0BA6F71AB
NUS Download Finished.

--Bdr9 12:06, 23 August 2009 (UTC)

You have a incorrect key.bin file, go dump one from your Wii. LoganA (talkcontribs) 21:47, 23 August 2009 (UTC)

NUSD_13beta - Application Error

I get a weird error message when running it.
:NUSD_13beta - Application Error
:The application failed to initialize properly (0xc0000135). Click OK to terminate application.

Any help? Thanks! Mp3c 03:06, 8 October 2009 (UTC)

You do not meet the prerequisites of the program. To be more specific, you do not have the .NET Framework 2.0 installed. --WB3000 21:19, 27 October 2009 (UTC)

Full restore

Could you please tell me if can i use this tool to completely restore my wii as if it were never hacked (patched)? I'm asking it because a stupid friend of mine put all that shitty cIOSCORP inside my wii and i don't wanted it, can i use this tool or anything else to remove it and make my wii look just fine? (just a little note: really I didn't wanted it!) Thanks for your comprehension and help! --balta 20:54, 2 December 2009 (UTC)

401 Unauthorized?

Im really sorry if this was already answered somewhere, but anyways:

I was trying to download BC (title ID: 00000001-0000010)

and it gave me the 401 error: --- 00000001-0000010 --- Starting NUS Download. Please be patient! Grabbing tmd... Download Failed: tmd

- Reason: (401) Unauthorized.

I have key.bin and everything, and I'm connected to the internet. Help? :) Quinnfap 19:48, 29 January 2010 (UTC)

I just tried and it worked fine...What version where you trying to download? Can you repeat the error? --SifJar 19:58, 29 January 2010 (UTC)

Size DOES Matter

Original page text regarding size: After the initial release, there were concerns rising about differences in file sizes between official WADs and NUSD ones. A first, obvious difference is in that official ones have a footer, and NUSD packed ones do not. This adds a few bytes onto the official ones which will not be present.

A second difference may be noticed in the Certificate Chain added to the WAD. While it may appear entirely different, it is simply ordered in a different way, and the Wii sees nothing different. V1.1 of NUSD will order the certs in the most common way, so that difference is covered.

The only real difference is in some tickets. NUS has a variation on the ticket for a title, as do the WADs that come in discs. While they are different, the only changed values are small (ticket_id and DLC purchases). The big things like Title Key remain intact. There has been no issues using these tickets, which is understandable as many are probably on your Wii right now.

I think you should write out the footer because I've found for some things (comex's formatter), it will fail an assert and completely crash because (as far as I can tell) the sizes differ. Could you do something about this and try to make the wads 1:1 with official wads? Thanks! tpw_rules 21:51, 11 February 2010 (UTC)

NUS Downloader works under Arch Linux using WINE 1.7-44-2 --PCMRShadowWolf (talk) 23:36, 14 June 2015 (CEST)

Rar file doesn’t open

It says it’s like damaged or something, not even 7 zip works

spam filter

I tried to replace the website link with the link of the same website, and it worked the first time, but it broke

I went to fix it and the spam filter decided to blacklist "" so I can't either fix it or change it back to normal

Apps from NUS not working on v514 (4.3E PAL)

I've been playing around with NUS and Dolphin 2.0E, but I wanted to start using 4.3E. I downloaded the latest versions of the pre-installed apps but they automatically put me back to the Wii Menu, and I can't use them. Anyone have any suggestions?

Are you launching them from the Wii Menu or from the Dolphin menu? The Dolphin menu doesn’t always launch things properly if a certain file is present in the filesystem. Hallowizer (talk) 19:40, 10 May 2022 (CEST)